Intermittent authentication failures
Incident Report for Beyond Identity
Postmortem

Summary

Intermittent authentication failures occurred between June 7th, 2022, at 1:06 pm (CDT) and 1:38 pm (CDT).

Cause

A specific user action in a specific sequence caused the directory service to crash. The directory service recovered itself immediately. During the few seconds it took for the directory service to come back online, authentications failed.

Mitigation

The site reliability engineering team instantly identified the root cause and prevented the sequence from being executed. The software engineering team implemented a permanent fix to the directory service to address the specific use case.

Posted Jun 08, 2022 - 11:41 CDT

Resolved
This incident has been resolved.
Posted Jun 07, 2022 - 17:04 CDT
Update
We are continuing to monitor for any further issues.
Posted Jun 07, 2022 - 14:10 CDT
Monitoring
We identified an issue with the authentication service. The issue was fixed within minutes. The engineering team is monitoring the situation.
Posted Jun 07, 2022 - 14:06 CDT
This incident affected: Authentication Service.