Authentication issues
Incident Report for Beyond Identity
Postmortem

Summary

A third-party service provider's partial outage affected some customer networks accessing the cloud services. Our services were impacted from 12/5/2022, 14:00 CST, to 12/5/2022, 14:55 CST. The estimated partial outage lasted 55 minutes. The SRE team reacted promptly and identified that it was a third-party issue. The issue was resolved while preparing to fail over to another data center.

Customer Impact

During the partial outage, some customers were unable to authenticate.

Mitigation and resolution

While testing internally, some team members could authenticate, and some did not. Due to the intermittent failures, Beyond Identity investigated and assessed the impact to minimize the recovery impact on the user base.

The SRE team started to prepare for failing over to another data center.

By the time the preparations were complete, the service provider had restored the service.

Posted Dec 07, 2022 - 09:24 CST

Resolved
The incident has been resolved. The postmortem will be provided in a timely manner.
Posted Dec 05, 2022 - 15:36 CST
Monitoring
The service has been recovered. The site reliability engineering team will continue to monitor.
Posted Dec 05, 2022 - 15:03 CST
Identified
We have identified a third-party service provider-related internet connection issue causing a partial outage. The engineering team is performing activities to recover.
Posted Dec 05, 2022 - 14:42 CST
Update
We are continuing to investigate this issue.
Posted Dec 05, 2022 - 14:29 CST
Investigating
We have identified issues with authentication. We are investigating the issue.
Posted Dec 05, 2022 - 14:26 CST
This incident affected: USA (USA - Authentication Service).