Windows application 2.10.0 missing DLL
Incident Report for Beyond Identity
Postmortem

Lead up

Customer reported via user feedback that they experienced an error when updating the software. Support engaged to investigate with help from a developer. While investigating the issue we discovered an unrelated missing DLL issue. This was discovered by examination of the user’s application logs which displayed an exception while trying to check for updates.

Mitigation and Resolution

  1. The the 2.10.0 release installer was replaced with 2.9.0 release installer to prevent further installations of impacted version.
  2. A fix was created for the missing DLL and the fixed version was released as 2.10.1.

Preventive Actions

QA team is going to add testing for upgrading to newer version as part of their process to ensure that automatic updates feature is not broken.

Posted Jul 27, 2020 - 09:15 CDT

Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 11:52 CDT
Monitoring
The Windows installer 2.10.0 has been reverted in the production. New installations are not impacted by the issue.
Posted Jul 23, 2020 - 10:12 CDT
Identified
We are removing the 2.10.0 Windows installer from production.
Posted Jul 23, 2020 - 09:34 CDT
Update
We are continuing to investigate this issue.
Posted Jul 23, 2020 - 09:16 CDT
Investigating
We have created an installer package for Windows users that seems to have a missing DLL file. Our engineering team is investigating the issue.
Posted Jul 23, 2020 - 09:14 CDT
This incident affected: Windows Platform Authenticator Application.