Third party service interruption
Incident Report for Beyond Identity
Postmortem

The DNS service provider experienced an outage and has published a detailed report https://blog.cloudflare.com/cloudflare-outage-on-june-21-2022/
The incident started at 1:27 AM CDT on June 21st 2022. Beyond Identity's services were impacted for 53 minutes and experienced intermittent failures. The services recovered as the DNS service provider implemented a fix.

Posted Jun 22, 2022 - 10:29 CDT

Resolved
The DNS service provider had an outage that impacted our services.
Posted Jun 21, 2022 - 02:30 CDT